Users are experiencing reCaptcha errors while signing up
Incident Report for Trello
Resolved
This issue has been resolved.
Posted Sep 11, 2024 - 23:28 EDT
Monitoring
We have identified the root cause and the issue appears to be resolved.
Posted Sep 11, 2024 - 22:40 EDT
Investigating
Users attempting to sign up are encountering reCaptcha errors that are preventing a successful signup.
Posted Sep 11, 2024 - 22:08 EDT
This incident affected: Trello.com.